summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2020-01-13 15:16:41 -0800
committerMartin Braun <martin@gnuradio.org>2020-04-11 17:55:56 -0700
commit80c04479da962d048d41165081b026aafdaa0316 (patch)
tree75201fab3d612c86322840690a63b056c9cc0a57 /gr-digital/lib/CMakeLists.txt
parentbad1040058004cd193bfea31c544f41a7e6d12e3 (diff)
Remove VOLK as a submodule
This removes the volk/ submodule pointer and updates the CMake to detect VOLK like any other dependency. The VOLK_MIN_VERSION CMake variable is added (and set to 2.1.0). The GR_VOLK_LIB variable is replaced with Volk::volk everywhere. The VOLK_INSTALL_LIBRARY_DIR and VOLK_INSTALL_INCLUDE_DIR variables weren't used and were removed. CMake will now fail if VOLK cannot be detected. Therefore, ENABLE_VOLK was also removed as a variable; all in-tree components may assume the existence of VOLK.
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index 2ab200c023..b44662994f 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -98,7 +98,7 @@ target_link_libraries(gnuradio-digital PUBLIC
gnuradio-blocks
gnuradio-analog
Boost::boost
- ${GR_VOLK_LIB}
+ Volk::volk
)