summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authormormj <34754695+mormj@users.noreply.github.com>2020-04-09 07:38:25 -0400
committerGitHub <noreply@github.com>2020-04-09 07:38:25 -0400
commit3c1750c481a578bd831fce933502fde88444eb54 (patch)
treeb2e3baf85a1e0605fdf4b0bfcf3e4d6280dfe439 /gr-digital/lib/CMakeLists.txt
parent7bc8622dda145164c97b73b1c8d4aaf3e0a8bf16 (diff)
digital: restructure equalizers and add dfe (#3306)
* digital: restructure equalizers and add dfe This commit restructures the linear equalizer to have a separate specifiable adaptive algorithm. Generally this works the same as the previous LMS and CMA decision directed equalizers, but also adds the ability to equalize using training sequences as well. Also, a Decision Feedback Equalizer structure is added * digital: more const in equalizers * digital: equalizers - more safety based on review * digital: dfe - use deque instead of vector for decision_history * digital - equalizers, further cleanup
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index 658fa95cba..2ab200c023 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -33,6 +33,7 @@ add_library(gnuradio-digital
crc32.cc
crc32_bb_impl.cc
crc32_async_bb_impl.cc
+ decision_feedback_equalizer_impl.cc
descrambler_bb_impl.cc
diff_decoder_bb_impl.cc
diff_encoder_bb_impl.cc
@@ -47,8 +48,10 @@ add_library(gnuradio-digital
header_buffer.cc
header_payload_demux_impl.cc
kurtotic_equalizer_cc_impl.cc
+ linear_equalizer_impl.cc
lms_dd_equalizer_cc_impl.cc
map_bb_impl.cc
+ meas_evm_cc_impl.cc
modulate_vector.cc
mpsk_snr_est.cc
mpsk_snr_est_cc_impl.cc
@@ -140,3 +143,4 @@ if(ENABLE_TESTING)
)
endforeach(qa_file)
endif(ENABLE_TESTING)
+