summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <johnathan@corganlabs.com>2015-04-06 20:22:14 -0700
committerJohnathan Corgan <johnathan@corganlabs.com>2015-04-06 20:27:38 -0700
commit13031bba1d7310c2b70830eb5a9a23e63808acc9 (patch)
tree44bd9ef2554ee7a925434fb802ccf5e8d1e65fcb /gr-digital/lib/CMakeLists.txt
parentd4b38e890c5ba3422160ba1ca5db3f55762eeb34 (diff)
digital: adds corr_est_cc correlation estimator block
This commit is almost entirely based on the correlate_and_sync_cc update by Nick Foster <bistromath@gmail.com> and Andy Walls <andy@silverblocksystems.net>, but has been renamed to corr_est_cc in order to be included in the 3.7 API without compatibility issues.
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index eb1008423b..0c213d7ac8 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -60,6 +60,7 @@ list(APPEND digital_sources
constellation_decoder_cb_impl.cc
constellation_receiver_cb_impl.cc
constellation_soft_decoder_cf_impl.cc
+ corr_est_cc_impl.cc
correlate_access_code_bb_impl.cc
correlate_access_code_tag_bb_impl.cc
correlate_access_code_bb_ts_impl.cc
@@ -85,6 +86,7 @@ list(APPEND digital_sources
kurtotic_equalizer_cc_impl.cc
lms_dd_equalizer_cc_impl.cc
map_bb_impl.cc
+ modulate_vector.cc
mpsk_receiver_cc_impl.cc
mpsk_snr_est.cc
mpsk_snr_est_cc_impl.cc