summaryrefslogtreecommitdiff
path: root/gr-digital/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2014-06-27 15:10:31 -0400
committerTom Rondeau <tom@trondeau.com>2014-06-28 13:58:57 -0400
commit0099eb9bd7a11afdf9276d6f4a5dafa757ebdb7c (patch)
treeb278b8598719ce8a1284b1707c49d4e39c1a639c /gr-digital/lib/CMakeLists.txt
parent3d8a19b55a15a285d5a95d1e786cb93e26cb4f3a (diff)
build: adds an ENABLE_STATIC_LIB option to cmake to build static (.a) versions of the libraries.
Diffstat (limited to 'gr-digital/lib/CMakeLists.txt')
-rw-r--r--gr-digital/lib/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/gr-digital/lib/CMakeLists.txt b/gr-digital/lib/CMakeLists.txt
index 926dca19fd..4ba821a307 100644
--- a/gr-digital/lib/CMakeLists.txt
+++ b/gr-digital/lib/CMakeLists.txt
@@ -217,3 +217,23 @@ add_dependencies(
gnuradio-analog
gnuradio-blocks
)
+
+if(ENABLE_STATIC_LIBS)
+ add_library(gnuradio-digital_static STATIC ${digital_sources})
+
+ add_dependencies(gnuradio-digital_static
+ digital_generated_includes
+ gnuradio-runtime_static
+ gnuradio-filter_static
+ gnuradio-analog_static
+ gnuradio-blocks_static)
+
+ if(NOT WIN32)
+ set_target_properties(gnuradio-digital_static
+ PROPERTIES OUTPUT_NAME gnuradio-digital)
+ endif(NOT WIN32)
+
+ install(TARGETS gnuradio-digital_static
+ ARCHIVE DESTINATION lib${LIB_SUFFIX} COMPONENT "digital_devel" # .lib file
+ )
+endif(ENABLE_STATIC_LIBS)