summaryrefslogtreecommitdiff
path: root/gr-digital/include/gnuradio/digital/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <tom@trondeau.com>2016-06-14 10:48:00 -0700
committerMartin Braun <martin.braun@ettus.com>2016-06-14 10:58:05 -0700
commit817f61bbdd180a2854116c85ccf1020e561c523f (patch)
tree883649968739a66c537e932c65c79e9387544a07 /gr-digital/include/gnuradio/digital/CMakeLists.txt
parentc475f14e4604b9bca25c08f1d30a2e8ff9bbcf26 (diff)
digital: Complete overhaul of protocol handling
See documentation for details. In brief: - digital_protocol_* classes added (replace packet header blocks) - header_buffer class added - Lots of QA - default packet formatter: contains access code and payload length fields. - counter packet formatter: also contains the bits/sym in the payload modulation and a packet number counter. - Also adds QA code and the infrastructure for C++ QA code in gr-digital. - New block to use the packet formatter objects. - The header and payload are transmitted as PDU messages out of different ports. - header_buffer class for header formatting. - Used by packet_formatter_x classes to more easily add and format header data for transmission. - New blocks that parse headers. - Handles either hard or soft bits. Produces an info message to instruct payload demod. - 'receive mode' to header_buffer class. - Designed to make extracting fields from the received header bits easier for packet formatter classes. Use extract_field[N] to get the different fields out of a collected set of header bits. * Docs describing both functions with small examples for how to use them. - Don't force access code to be a multiple of 8 - need to verify everything else handles this correctly. - Throw an exception in the ctor if setting the code failed and emit a log message. Committed-By: Martin Braun <martin.braun@ettus.com>
Diffstat (limited to 'gr-digital/include/gnuradio/digital/CMakeLists.txt')
-rw-r--r--gr-digital/include/gnuradio/digital/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/gr-digital/include/gnuradio/digital/CMakeLists.txt b/gr-digital/include/gnuradio/digital/CMakeLists.txt
index d8fe2b6c4d..1b22265853 100644
--- a/gr-digital/include/gnuradio/digital/CMakeLists.txt
+++ b/gr-digital/include/gnuradio/digital/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright 2011-2015 Free Software Foundation, Inc.
+# Copyright 2011-2016 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -65,6 +65,7 @@ install(FILES
glfsr_source_f.h
hdlc_deframer_bp.h
hdlc_framer_pb.h
+ header_buffer.h
header_payload_demux.h
kurtotic_equalizer_cc.h
lfsr.h
@@ -90,6 +91,14 @@ install(FILES
ofdm_sampler.h
ofdm_serializer_vcc.h
ofdm_sync_sc_cfb.h
+ header_format_base.h
+ header_format_default.h
+ header_format_counter.h
+ header_format_crc.h
+ header_format_ofdm.h
+ protocol_formatter_async.h
+ protocol_formatter_bb.h
+ protocol_parser_b.h
packet_header_default.h
packet_header_ofdm.h
packet_headergenerator_bb.h