summaryrefslogtreecommitdiff
path: root/gr-digital/include/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-09-28 22:59:51 -0700
committerJosh Blum <josh@joshknows.com>2011-09-28 22:59:51 -0700
commitb06328b4adee941fe62f12a848cc903097711bdd (patch)
treefa8b6d5aaadd6bb70786e57891b52a7a17b0b3f6 /gr-digital/include/CMakeLists.txt
parent3f7db0afa99caeecb18428d7514dadd380d88d56 (diff)
parent3e8c3125da6234c4d1f8c0eaf869bc86923cb292 (diff)
Merge branch 'digital' of https://github.com/trondeau/gnuradio into digital
Conflicts: gr-digital/lib/Makefile.am gr-digital/python/__init__.py
Diffstat (limited to 'gr-digital/include/CMakeLists.txt')
-rw-r--r--gr-digital/include/CMakeLists.txt44
1 files changed, 44 insertions, 0 deletions
diff --git a/gr-digital/include/CMakeLists.txt b/gr-digital/include/CMakeLists.txt
new file mode 100644
index 0000000000..7b38e645bd
--- /dev/null
+++ b/gr-digital/include/CMakeLists.txt
@@ -0,0 +1,44 @@
+# Copyright 2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Install header files
+########################################################################
+INSTALL(FILES
+ digital_api.h
+ digital_binary_slicer_fb.h
+ digital_clock_recovery_mm_cc.h
+ digital_clock_recovery_mm_ff.h
+ digital_constellation.h
+ digital_constellation_receiver_cb.h
+ digital_constellation_decoder_cb.h
+ digital_correlate_access_code_bb.h
+ digital_costas_loop_cc.h
+ digital_cma_equalizer_cc.h
+ digital_crc32.h
+ digital_fll_band_edge_cc.h
+ digital_lms_dd_equalizer_cc.h
+ digital_kurtotic_equalizer_cc.h
+ digital_metric_type.h
+ digital_mpsk_receiver_cc.h
+ digital_gmskmod_bc.h
+ digital_cpmmod_bc.h
+ DESTINATION ${GR_INCLUDE_DIR}/gnuradio
+ COMPONENT "digital_devel"
+)