summaryrefslogtreecommitdiff
path: root/gr-blocks/python/blocks/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Reynwar <ben@reynwar.net>2013-03-11 20:30:13 -0700
committerBen Reynwar <ben@reynwar.net>2013-03-11 20:30:13 -0700
commitfe9b0ee3ea739ac07321acd31fc5824192cf7cb8 (patch)
tree7a1abd82bd7d726f0b906706a9410576802e7fa8 /gr-blocks/python/blocks/CMakeLists.txt
parente8bf0ad5a721645f81b7c90743b4867b352d504c (diff)
blocks: Updating testing environment.
Diffstat (limited to 'gr-blocks/python/blocks/CMakeLists.txt')
-rw-r--r--gr-blocks/python/blocks/CMakeLists.txt19
1 files changed, 10 insertions, 9 deletions
diff --git a/gr-blocks/python/blocks/CMakeLists.txt b/gr-blocks/python/blocks/CMakeLists.txt
index 841588799b..312445e2b3 100644
--- a/gr-blocks/python/blocks/CMakeLists.txt
+++ b/gr-blocks/python/blocks/CMakeLists.txt
@@ -34,16 +34,17 @@ GR_PYTHON_INSTALL(
########################################################################
if(ENABLE_TESTING)
-list(APPEND GR_TEST_PYTHON_DIRS
- ${CMAKE_BINARY_DIR}/gr-blocks/python
- ${CMAKE_BINARY_DIR}/gr-blocks/swig
-)
-list(APPEND GR_TEST_TARGET_DEPS gnuradio-blocks)
+ set(GR_TEST_TARGET_DEPS "")
+ set(GR_TEST_LIBRARY_DIRS "")
+ set(GR_TEST_PYTHON_DIRS
+ ${CMAKE_BINARY_DIR}/gruel/src/python
+ ${CMAKE_BINARY_DIR}/gnuradio-core/src/python
+ )
-include(GrTest)
-file(GLOB py_qa_test_files "qa_*.py")
-foreach(py_qa_test_file ${py_qa_test_files})
+ include(GrTest)
+ file(GLOB py_qa_test_files "qa_*.py")
+ foreach(py_qa_test_file ${py_qa_test_files})
get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
-endforeach(py_qa_test_file)
+ endforeach(py_qa_test_file)
endif(ENABLE_TESTING)