summaryrefslogtreecommitdiff
path: root/gr-blocks/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2013-03-17 11:43:10 -0400
committerTom Rondeau <trondeau@vt.edu>2013-03-17 11:43:10 -0400
commitee2b700f72503d6e7f62adbfb7dff9997b9cb003 (patch)
tree2c7e91d03fb5c605c6deebac9077c1bc41bce13d /gr-blocks/lib/CMakeLists.txt
parentf15400470ce5cb68f5339ead7af726b8bbafd364 (diff)
parent65d88f0b28e233c82bc4f0c07072085a3d18c163 (diff)
Merge branch 'master' into next
Conflicts: gr-blocks/swig/blocks_swig.i
Diffstat (limited to 'gr-blocks/lib/CMakeLists.txt')
-rw-r--r--gr-blocks/lib/CMakeLists.txt21
1 files changed, 20 insertions, 1 deletions
diff --git a/gr-blocks/lib/CMakeLists.txt b/gr-blocks/lib/CMakeLists.txt
index de73a8a308..6e2b583308 100644
--- a/gr-blocks/lib/CMakeLists.txt
+++ b/gr-blocks/lib/CMakeLists.txt
@@ -114,6 +114,9 @@ expand_cc_h_impl(sub_XX ss ii ff cc)
expand_cc_h_impl(xor_XX bb ss ii)
expand_cc_h_impl(packed_to_unpacked_XX bb ss ii)
expand_cc_h_impl(unpacked_to_packed_XX bb ss ii)
+expand_cc_h_impl(vector_insert_X b s i f c)
+expand_cc_h_impl(vector_sink_X b s i f c)
+expand_cc_h_impl(vector_source_X b s i f c)
########################################################################
# Setup the include and linker paths
@@ -147,6 +150,9 @@ list(APPEND gr_blocks_sources
fxpt.cc
wavfile.cc
add_ff_impl.cc
+ annotator_1to1_impl.cc
+ annotator_alltoall_impl.cc
+ annotator_raw_impl.cc
bin_statistics_f_impl.cc
burst_tagger_impl.cc
char_to_float_impl.cc
@@ -159,8 +165,10 @@ list(APPEND gr_blocks_sources
complex_to_mag_squared_impl.cc
complex_to_arg_impl.cc
conjugate_cc_impl.cc
+ copy_impl.cc
deinterleave_impl.cc
delay_impl.cc
+ endian_swap_impl.cc
file_descriptor_sink_impl.cc
file_descriptor_source_impl.cc
file_sink_impl.cc
@@ -174,6 +182,7 @@ list(APPEND gr_blocks_sources
float_to_short_impl.cc
float_array_to_uchar.cc
float_to_uchar_impl.cc
+ head_impl.cc
int_to_float_impl.cc
interleave_impl.cc
interleaved_short_array_to_complex.cc
@@ -191,6 +200,9 @@ list(APPEND gr_blocks_sources
multiply_const_cc_impl.cc
multiply_const_ff_impl.cc
nlog10_ff_impl.cc
+ nop_impl.cc
+ null_sink_impl.cc
+ null_source_impl.cc
pack_k_bits_bb_impl.cc
patterned_interleaver_impl.cc
pdu.cc
@@ -206,6 +218,7 @@ list(APPEND gr_blocks_sources
rms_ff_impl.cc
short_to_char_impl.cc
short_to_float_impl.cc
+ skiphead_impl.cc
socket_pdu_impl.cc
stream_mux_impl.cc
stream_pdu_base.cc
@@ -228,6 +241,7 @@ list(APPEND gr_blocks_sources
udp_source_impl.cc
unpack_k_bits_bb_impl.cc
vco_f_impl.cc
+ vector_map_impl.cc
vector_to_stream_impl.cc
vector_to_streams_impl.cc
wavfile_sink_impl.cc
@@ -268,15 +282,19 @@ GR_LIBRARY_FOO(gnuradio-blocks RUNTIME_COMPONENT "blocks_runtime" DEVEL_COMPONEN
if(ENABLE_TESTING)
include(GrTest)
- include_directories(${CPPUNIT_INCLUDE_DIRS})
+ include_directories(
+ ${GR_FILTER_INCLUDE_DIRS}
+ ${CPPUNIT_INCLUDE_DIRS})
link_directories(${CPPUNIT_LIBRARY_DIRS})
list(APPEND test_gr_blocks_sources
${CMAKE_CURRENT_SOURCE_DIR}/test_gr_blocks.cc
${CMAKE_CURRENT_SOURCE_DIR}/qa_blocks.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/qa_block_tags.cc
${CMAKE_CURRENT_SOURCE_DIR}/qa_fxpt.cc
${CMAKE_CURRENT_SOURCE_DIR}/qa_fxpt_nco.cc
${CMAKE_CURRENT_SOURCE_DIR}/qa_fxpt_vco.cc
+ ${CMAKE_CURRENT_SOURCE_DIR}/qa_rotator.cc
)
add_executable(test-gr-blocks ${test_gr_blocks_sources})
@@ -287,6 +305,7 @@ if(ENABLE_TESTING)
test-gr-blocks
gnuradio-core
gnuradio-blocks
+ gnuradio-filter
${Boost_LIBRARIES}
${CPPUNIT_LIBRARIES}
)