summaryrefslogtreecommitdiff
path: root/gr-blocks/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2012-10-03 18:53:21 -0700
committerNicholas Corgan <nick.corgan@ettus.com>2012-10-03 18:53:21 -0700
commitd89012d1f6d50d41eb79ad5186161e4ae7b7cf08 (patch)
treeb61b993e6ceb25cea4272244a02acef70ba3232e /gr-blocks/lib/CMakeLists.txt
parentc151fdd36035bea7187f00d508691199e9170a5a (diff)
blocks: fixed MSVC compatibility issue
Diffstat (limited to 'gr-blocks/lib/CMakeLists.txt')
-rw-r--r--gr-blocks/lib/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/gr-blocks/lib/CMakeLists.txt b/gr-blocks/lib/CMakeLists.txt
index b06f466752..0b6c892985 100644
--- a/gr-blocks/lib/CMakeLists.txt
+++ b/gr-blocks/lib/CMakeLists.txt
@@ -18,6 +18,11 @@
# Boston, MA 02110-1301, USA.
########################################################################
+# Setup compatibility checks and defines
+########################################################################
+include(${CMAKE_CURRENT_SOURCE_DIR}/ConfigChecks.cmake)
+
+########################################################################
# generate helper scripts to expand templated files
########################################################################
include(GrPython)
@@ -171,6 +176,7 @@ list(APPEND gr_blocks_sources
list(APPEND blocks_libs
gnuradio-core
+ volk
${Boost_LIBRARIES}
${BLOCKS_LIBRARIES}
)