summaryrefslogtreecommitdiff
path: root/gr-blocks/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <jcorgan@corganenterprises.com>2012-06-08 14:48:46 -0700
committerJohnathan Corgan <jcorgan@corganenterprises.com>2012-06-08 14:48:46 -0700
commit9752fabd851d05c77b0526e7a28c9c7099e54fc6 (patch)
tree3e14923d95e6a1cb080d8ca6e44e8bf7f9964673 /gr-blocks/lib/CMakeLists.txt
parent630cd06cb33d628fa6426866f006580aad30f84b (diff)
blocks: added blocks_add_const_xx
Diffstat (limited to 'gr-blocks/lib/CMakeLists.txt')
-rw-r--r--gr-blocks/lib/CMakeLists.txt7
1 files changed, 4 insertions, 3 deletions
diff --git a/gr-blocks/lib/CMakeLists.txt b/gr-blocks/lib/CMakeLists.txt
index f5ed77f3b6..334d188302 100644
--- a/gr-blocks/lib/CMakeLists.txt
+++ b/gr-blocks/lib/CMakeLists.txt
@@ -41,8 +41,8 @@ if __name__ == '__main__':
macro(expand_cc_h_impl root)
#make a list of all the generated files
- unset(expanded_files_cc)
- unset(expanded_files_h)
+ unset(expanded_files_cc_impl)
+ unset(expanded_files_h_impl)
foreach(sig ${ARGN})
string(REGEX REPLACE "X+" ${sig} name ${root})
list(APPEND expanded_files_cc_impl ${CMAKE_CURRENT_BINARY_DIR}/${name}_impl.cc)
@@ -85,7 +85,8 @@ endmacro(expand_cc_h_impl)
########################################################################
# Invoke macro to generate various sources
########################################################################
-expand_cc_h_impl(add_XX ss ii cc)
+expand_cc_h_impl(add_XX ss ii cc)
+expand_cc_h_impl(add_const_XX ss ii ff cc)
########################################################################
# Setup the include and linker paths