summaryrefslogtreecommitdiff
path: root/gr-blocks/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <jcorgan@corganenterprises.com>2012-06-14 10:09:14 -0700
committerJohnathan Corgan <jcorgan@corganenterprises.com>2012-06-14 10:09:14 -0700
commit6a2d514fab10f692d49f724d1d09afce1c603fa0 (patch)
tree301bb37ed3158e4506cb206f5c18ade499da633c /gr-blocks/lib/CMakeLists.txt
parent926f7cba99c4fa3906853e11ff4e91eea93a5a53 (diff)
blocks: added multiply_xx, some cleanup on add_xx
Diffstat (limited to 'gr-blocks/lib/CMakeLists.txt')
-rw-r--r--gr-blocks/lib/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/gr-blocks/lib/CMakeLists.txt b/gr-blocks/lib/CMakeLists.txt
index 334d188302..7894c34eac 100644
--- a/gr-blocks/lib/CMakeLists.txt
+++ b/gr-blocks/lib/CMakeLists.txt
@@ -87,6 +87,7 @@ endmacro(expand_cc_h_impl)
########################################################################
expand_cc_h_impl(add_XX ss ii cc)
expand_cc_h_impl(add_const_XX ss ii ff cc)
+expand_cc_h_impl(multiply_XX ss ii)
########################################################################
# Setup the include and linker paths
@@ -112,6 +113,8 @@ link_directories(${Boost_LIBRARY_DIRS})
list(APPEND gr_blocks_sources
${generated_sources}
add_ff_impl.cc
+ multiply_cc_impl.cc
+ multiply_ff_impl.cc
)
list(APPEND blocks_libs