summaryrefslogtreecommitdiff
path: root/gr-blocks/include/blocks/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2013-03-16 19:30:59 -0400
committerTom Rondeau <trondeau@vt.edu>2013-03-16 23:52:20 -0400
commita792bb88f3c3caa347506503de973aafaf78e0af (patch)
treea0332d76356df331134f340a2ce527e884c1bdd3 /gr-blocks/include/blocks/CMakeLists.txt
parentdd5e9df6bf93b676ffa8051b68bd2dbb8d71c15c (diff)
blocks: moving copy, endian_swap, head, skiphead, vector_source/sink/insert to gr-blocks.
Diffstat (limited to 'gr-blocks/include/blocks/CMakeLists.txt')
-rw-r--r--gr-blocks/include/blocks/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/gr-blocks/include/blocks/CMakeLists.txt b/gr-blocks/include/blocks/CMakeLists.txt
index 10e132ed92..a7cc1e0a31 100644
--- a/gr-blocks/include/blocks/CMakeLists.txt
+++ b/gr-blocks/include/blocks/CMakeLists.txt
@@ -88,6 +88,9 @@ expand_h(sub_XX ss ii ff cc)
expand_h(xor_XX bb ss ii)
expand_h(packed_to_unpacked_XX bb ss ii)
expand_h(unpacked_to_packed_XX bb ss ii)
+expand_h(vector_insert_X b s i f c)
+expand_h(vector_sink_X b s i f c)
+expand_h(vector_source_X b s i f c)
add_custom_target(blocks_generated_includes DEPENDS
${generated_includes}
@@ -106,10 +109,14 @@ install(FILES
fxpt_nco.h
fxpt_vco.h
log2_const.h
+ rotator.h
nco.h
vco.h
wavfile.h
add_ff.h
+ annotator_1to1.h
+ annotator_alltoall.h
+ annotator_raw.h
bin_statistics_f.h
burst_tagger.h
char_to_float.h
@@ -122,8 +129,10 @@ install(FILES
complex_to_mag_squared.h
complex_to_arg.h
conjugate_cc.h
+ copy.h
deinterleave.h
delay.h
+ endian_swap.h
file_source.h
file_meta_sink.h
file_meta_source.h
@@ -132,6 +141,7 @@ install(FILES
float_to_int.h
float_to_short.h
float_to_uchar.h
+ head.h
int_to_float.h
interleave.h
interleaved_short_to_complex.h
@@ -161,6 +171,7 @@ install(FILES
rms_ff.h
short_to_char.h
short_to_float.h
+ skiphead.h
socket_pdu.h
stream_mux.h
stream_to_streams.h