summaryrefslogtreecommitdiff
path: root/gr-audio/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2012-04-03 11:35:35 -0400
committerTom Rondeau <trondeau@vt.edu>2012-04-03 12:26:34 -0400
commit7dc08ba2875c0dace0432cd514add6ce2b085f44 (patch)
treee6a01fd07cd6c24040886a805105e6323a969834 /gr-audio/CMakeLists.txt
parent0dd3e32b5526c085a983d7ff235bac61ec2c52ff (diff)
examples: Reworked locations and installation of examples.
All python and GRC examples directly associated with a top-level component are now in that examples directory. Examples are split into c++, python, and grc dirs but are all installed into $prefix/share/gnuradio/examples/<component>.
Diffstat (limited to 'gr-audio/CMakeLists.txt')
-rw-r--r--gr-audio/CMakeLists.txt12
1 files changed, 11 insertions, 1 deletions
diff --git a/gr-audio/CMakeLists.txt b/gr-audio/CMakeLists.txt
index 7038b9b0f4..f9975cf088 100644
--- a/gr-audio/CMakeLists.txt
+++ b/gr-audio/CMakeLists.txt
@@ -33,6 +33,8 @@ GR_REGISTER_COMPONENT("gr-audio" ENABLE_GR_AUDIO
GR_SET_GLOBAL(GR_AUDIO_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/include)
+SET(GR_PKG_AUDIO_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/audio)
+
########################################################################
# Begin conditional configuration
########################################################################
@@ -65,6 +67,13 @@ CPACK_COMPONENT("audio_python"
DEPENDS "core_python;audio_runtime"
)
+CPACK_COMPONENT("audio_examples"
+ GROUP "Audio"
+ DISPLAY_NAME "Examples"
+ DESCRIPTION "Example programs"
+ DEPENDS "audio_runtime"
+)
+
CPACK_COMPONENT("audio_swig"
GROUP "Audio"
DISPLAY_NAME "SWIG"
@@ -77,12 +86,13 @@ CPACK_COMPONENT("audio_swig"
########################################################################
add_subdirectory(include)
add_subdirectory(lib)
-add_subdirectory(examples/c++)
add_subdirectory(doc)
+add_subdirectory(examples/c++)
if(ENABLE_PYTHON)
add_subdirectory(swig)
add_subdirectory(grc)
add_subdirectory(examples/python)
+ add_subdirectory(examples/grc)
endif(ENABLE_PYTHON)
########################################################################