summaryrefslogtreecommitdiff
path: root/gr-atsc/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
committerJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
commit71c0f14a46f85027b95f2f5f6d3d219cc9e3783e (patch)
tree046d89555243ede65bfc7bc0a6cbfc7f870ff4cb /gr-atsc/CMakeLists.txt
parent63b87bf4e6e9a2f1112c17c57796b69b3b8a2b3e (diff)
gr: the CMakeLists.txt took a chill pill
Diffstat (limited to 'gr-atsc/CMakeLists.txt')
-rw-r--r--gr-atsc/CMakeLists.txt22
1 files changed, 11 insertions, 11 deletions
diff --git a/gr-atsc/CMakeLists.txt b/gr-atsc/CMakeLists.txt
index 86aa53991a..9ed0844652 100644
--- a/gr-atsc/CMakeLists.txt
+++ b/gr-atsc/CMakeLists.txt
@@ -20,12 +20,12 @@
########################################################################
# Setup dependencies
########################################################################
-INCLUDE(GrBoost)
+include(GrBoost)
########################################################################
# Register component
########################################################################
-INCLUDE(GrComponent)
+include(GrComponent)
GR_REGISTER_COMPONENT("gr-atsc" ENABLE_GR_ATSC
Boost_FOUND
ENABLE_GR_CORE_
@@ -38,12 +38,12 @@ GR_SET_GLOBAL(GR_ATSC_INCLUDE_DIRS
########################################################################
# Begin conditional configuration
########################################################################
-IF(ENABLE_GR_ATSC)
+if(ENABLE_GR_ATSC)
########################################################################
# Setup CPack components
########################################################################
-INCLUDE(GrPackage)
+include(GrPackage)
CPACK_SET(CPACK_COMPONENT_GROUP_ATSC_DESCRIPTION "GNU Radio ATSC Blocks")
CPACK_COMPONENT("atsc_runtime"
@@ -84,23 +84,23 @@ CPACK_COMPONENT("atsc_swig"
########################################################################
# Add subdirectories
########################################################################
-ADD_SUBDIRECTORY(src/lib)
-IF(ENABLE_PYTHON)
- ADD_SUBDIRECTORY(src/python)
-ENDIF(ENABLE_PYTHON)
+add_subdirectory(src/lib)
+if(ENABLE_PYTHON)
+ add_subdirectory(src/python)
+endif(ENABLE_PYTHON)
########################################################################
# Create Pkg Config File
########################################################################
-CONFIGURE_FILE(
+configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-atsc.pc.in
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-atsc.pc
@ONLY)
-INSTALL(
+install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-atsc.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
COMPONENT "atsc_devel"
)
-ENDIF(ENABLE_GR_ATSC)
+endif(ENABLE_GR_ATSC)