summaryrefslogtreecommitdiff
path: root/gr-analog/python/analog/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Reynwar <ben@reynwar.net>2013-03-11 22:05:58 -0700
committerBen Reynwar <ben@reynwar.net>2013-03-11 22:05:58 -0700
commit90b6ccb6fca6dbeabb19804267a6e52e613f030d (patch)
treec0be8de3d41c4ff56ed7a31d42e2db0867c11227 /gr-analog/python/analog/CMakeLists.txt
parentfe9b0ee3ea739ac07321acd31fc5824192cf7cb8 (diff)
analog: Updating testing environment.
Diffstat (limited to 'gr-analog/python/analog/CMakeLists.txt')
-rw-r--r--gr-analog/python/analog/CMakeLists.txt21
1 files changed, 10 insertions, 11 deletions
diff --git a/gr-analog/python/analog/CMakeLists.txt b/gr-analog/python/analog/CMakeLists.txt
index a3f789ddfa..185cffff96 100644
--- a/gr-analog/python/analog/CMakeLists.txt
+++ b/gr-analog/python/analog/CMakeLists.txt
@@ -44,18 +44,17 @@ GR_PYTHON_INSTALL(
########################################################################
if(ENABLE_TESTING)
-list(APPEND GR_TEST_PYTHON_DIRS
- ${CMAKE_BINARY_DIR}/gr-analog/python
- ${CMAKE_BINARY_DIR}/gr-analog/swig
- ${CMAKE_BINARY_DIR}/gr-filter/python
- ${CMAKE_BINARY_DIR}/gr-filter/swig
-)
-list(APPEND GR_TEST_TARGET_DEPS gnuradio-analog gnuradio-filter gnuradio-fft)
+ set(GR_TEST_TARGET_DEPS "")
+ set(GR_TEST_LIBRARY_DIRS "")
+ set(GR_TEST_PYTHON_DIRS
+ ${CMAKE_BINARY_DIR}/gruel/src/python
+ ${CMAKE_BINARY_DIR}/gnuradio-core/src/python
+ )
-include(GrTest)
-file(GLOB py_qa_test_files "qa_*.py")
-foreach(py_qa_test_file ${py_qa_test_files})
+ include(GrTest)
+ file(GLOB py_qa_test_files "qa_*.py")
+ foreach(py_qa_test_file ${py_qa_test_files})
get_filename_component(py_qa_test_name ${py_qa_test_file} NAME_WE)
GR_ADD_TEST(${py_qa_test_name} ${PYTHON_EXECUTABLE} ${PYTHON_DASH_B} ${py_qa_test_file})
-endforeach(py_qa_test_file)
+ endforeach(py_qa_test_file)
endif(ENABLE_TESTING)