summaryrefslogtreecommitdiff
path: root/gr-analog/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <johnathan@corganlabs.com>2016-08-03 13:47:27 -0700
committerJohnathan Corgan <johnathan@corganlabs.com>2016-08-03 13:47:27 -0700
commitc7692c32cd91c0e98672ce0e997d35f9d3461dd3 (patch)
tree692a649a886250bf06dc56a5fabe73e4492a1efa /gr-analog/CMakeLists.txt
parent77f902e1a7d731805cfcd1a15d22d149898709b0 (diff)
cmake: nuke cpack from existence
CPack is not used, unmaintaned, and broken. This does not eliminate any MSVC build functionality.
Diffstat (limited to 'gr-analog/CMakeLists.txt')
-rw-r--r--gr-analog/CMakeLists.txt35
1 files changed, 0 insertions, 35 deletions
diff --git a/gr-analog/CMakeLists.txt b/gr-analog/CMakeLists.txt
index e0be42a0a5..3be716d7ab 100644
--- a/gr-analog/CMakeLists.txt
+++ b/gr-analog/CMakeLists.txt
@@ -51,40 +51,6 @@ SET(GR_PKG_ANALOG_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/analog)
if(ENABLE_GR_ANALOG)
########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_SET(CPACK_COMPONENT_GROUP_ANALOG_DESCRIPTION "GNU Radio Analog Blocks")
-
-CPACK_COMPONENT("analog_runtime"
- GROUP "Analog"
- DISPLAY_NAME "Runtime"
- DESCRIPTION "Dynamic link libraries"
- DEPENDS "runtime_runtime"
-)
-
-CPACK_COMPONENT("analog_devel"
- GROUP "Analog"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("analog_python"
- GROUP "Analog"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime"
- DEPENDS "runtime_python;analog_runtime"
-)
-
-CPACK_COMPONENT("analog_swig"
- GROUP "Analog"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;analog_python;analog_devel"
-)
-
-########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include/gnuradio/analog)
@@ -109,7 +75,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-analog.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "analog_devel"
)
endif(ENABLE_GR_ANALOG)