summaryrefslogtreecommitdiff
path: root/gnuradio-runtime/lib/pmt/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2013-04-15 11:59:20 -0400
committerTom Rondeau <trondeau@vt.edu>2013-04-15 11:59:20 -0400
commit427b8efd03394b724a2bf646f57aa49fe49374a5 (patch)
tree0b8bb1295b3142283d4c14fbf7f8a6af73766ba2 /gnuradio-runtime/lib/pmt/CMakeLists.txt
parentc018b14e025a52b96da2870e42896db04427e4c9 (diff)
runtime: added pmt_generated target for use as dependency.
Diffstat (limited to 'gnuradio-runtime/lib/pmt/CMakeLists.txt')
-rw-r--r--gnuradio-runtime/lib/pmt/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnuradio-runtime/lib/pmt/CMakeLists.txt b/gnuradio-runtime/lib/pmt/CMakeLists.txt
index e7bb4de91d..8d2dec8d14 100644
--- a/gnuradio-runtime/lib/pmt/CMakeLists.txt
+++ b/gnuradio-runtime/lib/pmt/CMakeLists.txt
@@ -85,6 +85,10 @@ list(APPEND gnuradio_pmt_libs
${LOG4CPP_LIBRARIES}
)
+add_custom_target(pmt_generated
+ DEPENDS ${PMT_SERIAL_TAGS_H} ${CMAKE_CURRENT_BINARY_DIR}/pmt_unv_int.h)
+
+
#Add Windows DLL resource file if using MSVC
if(MSVC)
include(${CMAKE_SOURCE_DIR}/cmake/Modules/GrVersion.cmake)