summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2012-05-01 11:18:31 -0400
committerTom Rondeau <trondeau@vt.edu>2012-05-01 11:29:14 -0400
commit8ee7c96ff6ffd8829a0dd29e4a4745eeaeee780f (patch)
tree4e55882d592625c19ab91fdf396db9cec8050529 /docs/CMakeLists.txt
parent141d2ec0a0c3d9c234622444b1f2a5e21fa08ae8 (diff)
docs: adds a 'make sphinx' target that can be run after 'make install' to generate the Python docs.
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index f67fdd7a86..24bf2405ea 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -21,12 +21,14 @@
# Setup dependencies
########################################################################
find_package(Doxygen)
+find_package(Sphinx)
########################################################################
# Register component
########################################################################
include(GrComponent)
GR_REGISTER_COMPONENT("doxygen" ENABLE_DOXYGEN DOXYGEN_FOUND)
+GR_REGISTER_COMPONENT("sphinx" ENABLE_SPHINX SPHINX_FOUND)
########################################################################
# Begin conditional configuration
@@ -48,3 +50,25 @@ CPACK_COMPONENT("docs"
add_subdirectory(doxygen)
endif(ENABLE_DOXYGEN)
+
+
+########################################################################
+# Begin conditional configuration
+########################################################################
+if(ENABLE_SPHINX)
+
+########################################################################
+# Setup CPack components
+########################################################################
+include(GrPackage)
+CPACK_COMPONENT("docs"
+ DISPLAY_NAME "Documentation"
+ DESCRIPTION "Sphinx generated documentation"
+)
+
+########################################################################
+# Add subdirectories
+########################################################################
+add_subdirectory(sphinx)
+
+endif(ENABLE_SPHINX)