summaryrefslogtreecommitdiff
path: root/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
committerJosh Blum <josh@joshknows.com>2011-10-08 17:11:12 -0700
commit71c0f14a46f85027b95f2f5f6d3d219cc9e3783e (patch)
tree046d89555243ede65bfc7bc0a6cbfc7f870ff4cb /docs/CMakeLists.txt
parent63b87bf4e6e9a2f1112c17c57796b69b3b8a2b3e (diff)
gr: the CMakeLists.txt took a chill pill
Diffstat (limited to 'docs/CMakeLists.txt')
-rw-r--r--docs/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
index 097e1fc678..45f9b0102e 100644
--- a/docs/CMakeLists.txt
+++ b/docs/CMakeLists.txt
@@ -20,23 +20,23 @@
########################################################################
# Setup dependencies
########################################################################
-FIND_PACKAGE(Doxygen)
+find_package(Doxygen)
########################################################################
# Register component
########################################################################
-INCLUDE(GrComponent)
+include(GrComponent)
GR_REGISTER_COMPONENT("doxygen" ENABLE_DOXYGEN DOXYGEN_FOUND)
########################################################################
# Begin conditional configuration
########################################################################
-IF(ENABLE_DOXYGEN)
+if(ENABLE_DOXYGEN)
########################################################################
# Setup CPack components
########################################################################
-INCLUDE(GrPackage)
+include(GrPackage)
CPACK_COMPONENT("docs"
DISPLAY_NAME "Documentation"
DESCRIPTION "Doxygen generated documentation"
@@ -45,6 +45,6 @@ CPACK_COMPONENT("docs"
########################################################################
# Add subdirectories
########################################################################
-ADD_SUBDIRECTORY(doxygen)
+add_subdirectory(doxygen)
-ENDIF(ENABLE_DOXYGEN)
+endif(ENABLE_DOXYGEN)