summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authoreb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>2006-08-05 03:03:37 +0000
committereb <eb@221aa14e-8319-0410-a670-987f0aec2ac5>2006-08-05 03:03:37 +0000
commite20a5fd252815a5799908598abdecb4dafa73389 (patch)
tree617566f395759324391b95dbc621568cb0cbd2ea /configure.ac
parent46d07539cf7c560031582c0cd80796ae8694996e (diff)
believed to have fixed ticket:7
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3163 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 68e8837c5c..810282a37f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,8 @@ AC_CHECK_LIB(m, sincosf,[AC_DEFINE([HAVE_SINCOSF],[1],[Define to 1 if your syste
AC_CHECK_LIB(m, sinf, [AC_DEFINE([HAVE_SINF],[1],[Define to 1 if your system has `sinf'.])])
AC_CHECK_LIB(m, cosf, [AC_DEFINE([HAVE_COSF],[1],[Define to 1 if your system has `cosf'.])])
AC_CHECK_LIB(m, trunc, [AC_DEFINE([HAVE_TRUNC],[1],[Define to 1 if your system has `trunc'.])])
+AC_CHECK_LIB(m, exp10, [AC_DEFINE([HAVE_EXP10],[1],[Define to 1 if your system has 'exp10'.])])
+
AH_BOTTOM([
#ifndef HAVE_TRUNC
#include <math.h>
@@ -98,6 +100,14 @@ inline static double trunc(double x)
return x >= 0 ? floor(x) : ceil(x);
}
#endif
+
+#ifndef HAVE_EXP10
+#include <math.h>
+inline static double exp10(double x)
+{
+ return pow(10.0, x);
+}
+#endif
])
GR_CHECK_SHM_OPEN