summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTom Rondeau <trondeau@vt.edu>2010-11-16 07:56:14 -0800
committerTom Rondeau <trondeau@vt.edu>2010-11-16 07:56:14 -0800
commit559d397de9ba937f470d27a7ad8b8d15f8f2f90f (patch)
tree221f32c0c10e55f9072fb22623e01fcd1dd63353 /configure.ac
parenta6b5781e36ff75adb1e4d39d755d4ab8f5efd9dd (diff)
parent53eee1c624794056fcba50a5eb50b864cbf159dd (diff)
Merge branch 'next' into tagging
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3c23c55e66..91bbe755a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,6 +19,13 @@ dnl Boston, MA 02110-1301, USA.
AC_INIT
AC_PREREQ(2.57)
+
+dnl Set the prefix to the default when --prefix is not specified.
+dnl This is critical for variable substitutions in the configure.
+if test "${prefix}" = "NONE"; then
+ prefix=${ac_default_prefix}
+fi
+
AM_CONFIG_HEADER(config.h)
AC_CONFIG_SRCDIR([gnuradio-core/src/lib/runtime/gr_vmcircbuf.cc])