summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohnathan Corgan <johnathan@corganlabs.com>2012-12-07 10:06:29 -0800
committerJohnathan Corgan <johnathan@corganlabs.com>2012-12-07 10:07:52 -0800
commitddb6ada4dbd0fa8db97ba6f2f4d2d8cb4149c8f1 (patch)
tree5faf735022d164b5f222a2d1b6e11b0b901f8a28 /CMakeLists.txt
parent583ba9b96ce3c3e52173cd847a0c00ff10c1cf85 (diff)
parent52ca5e2765b7a4532d26502b5b76b7c85c5019d7 (diff)
Merge branch 'master' into next
Conflicts: gnuradio-core/src/lib/runtime/gr_basic_block.h
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b0bb0a5d73..af57006e14 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,13 @@ SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O2")
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O2")
########################################################################
+# Environment setup
+########################################################################
+IF(NOT DEFINED BOOST_ROOT)
+ SET(BOOST_ROOT ${CMAKE_INSTALL_PREFIX})
+ENDIF()
+
+########################################################################
# Import executables from a native build (for cross compiling)
# http://www.vtk.org/Wiki/CMake_Cross_Compiling#Using_executables_in_the_build_created_during_the_build
########################################################################