From b48de00cfefac61414b0ea568e5014f2794e50cd Mon Sep 17 00:00:00 2001
From: jcorgan <jcorgan@221aa14e-8319-0410-a670-987f0aec2ac5>
Date: Fri, 20 Jun 2008 18:14:47 +0000
Subject: Merged -r8639:8641 from jcorgan/gruel into trunk.  Adds libgruel, the
 GNU Radio Utility Etcetera Library.  See README for description.

git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@8642 221aa14e-8319-0410-a670-987f0aec2ac5
---
 gruel/src/lib/Makefile.am | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)
 create mode 100644 gruel/src/lib/Makefile.am

(limited to 'gruel/src/lib/Makefile.am')

diff --git a/gruel/src/lib/Makefile.am b/gruel/src/lib/Makefile.am
new file mode 100644
index 0000000000..972ff4ca92
--- /dev/null
+++ b/gruel/src/lib/Makefile.am
@@ -0,0 +1,39 @@
+#
+# Copyright 2008 Free Software Foundation, Inc.
+# 
+# This file is part of GNU Radio
+# 
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+# 
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+# 
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+# 
+
+include $(top_srcdir)/Makefile.common
+
+AM_CPPFLAGS = $(DEFINES) $(BOOST_CFLAGS) $(GRUEL_INCLUDES) $(WITH_INCLUDES)
+
+lib_LTLIBRARIES = libgruel.la
+
+# These are the source files that go into the gruel shared library
+libgruel_la_SOURCES = \
+	realtime.cc
+
+# magic flags
+libgruel_la_LDFLAGS = $(NO_UNDEFINED)
+
+# link the library against the c++ standard library
+libgruel_la_LIBADD = \
+	-lstdc++			
+
+noinst_HEADERS =
-- 
cgit v1.2.3