From 7f8331808f99a9747bed39e55bbee98bc58c6038 Mon Sep 17 00:00:00 2001
From: Tom Rondeau <trondeau@vt.edu>
Date: Wed, 2 May 2012 11:45:29 -0400
Subject: build: reworking cmake structure for include and lib directories. I
 think this is cleaner.

We also probably don't need the link_directories (according to the cmake guys, this is no longer necessary).
---
 gr-fft/lib/CMakeLists.txt | 11 ++++-------
 1 file changed, 4 insertions(+), 7 deletions(-)

(limited to 'gr-fft/lib/CMakeLists.txt')

diff --git a/gr-fft/lib/CMakeLists.txt b/gr-fft/lib/CMakeLists.txt
index e2f17a1830..ea1248fbac 100644
--- a/gr-fft/lib/CMakeLists.txt
+++ b/gr-fft/lib/CMakeLists.txt
@@ -21,19 +21,16 @@
 # Setup the include and linker paths
 ########################################################################
 include_directories(
-    ${GNURADIO_CORE_INCLUDE_DIRS}
-    ${GR_FFT_INCLUDE_DIRS}
     ${CMAKE_CURRENT_SOURCE_DIR}
     ${CMAKE_CURRENT_BINARY_DIR}
+    ${GNURADIO_CORE_INCLUDE_DIRS}
+    ${GR_FFT_INCLUDE_DIRS}
+    ${Boost_INCLUDE_DIRS}
+    ${FFTW3F_INCLUDE_DIRS}
 )
 
-include_directories(${FFT_INCLUDE_DIRS})
 link_directories(${FFT_LIBRARY_DIRS})
-
-include_directories(${Boost_INCLUDE_DIRS})
 link_directories(${Boost_LIBRARY_DIRS})
-
-include_directories(${FFTW3F_INCLUDE_DIRS})
 link_directories(${FFTW3F_LIBRARY_DIRS})
 
 ########################################################################
-- 
cgit v1.2.3