From faab807cf5e8b4a4c950d1fd8ae6672296fb1ad9 Mon Sep 17 00:00:00 2001
From: Tom Rondeau <trondeau@vt.edu>
Date: Tue, 3 Apr 2012 18:21:52 -0400
Subject: Rework example directories. Gets rid of gnuradio-examples, moves
 these to more appropriate components.

gnuradio-core and grc now have their own examples directories for files directly related to them.
---
 gr-digital/examples/CMakeLists.txt | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)

(limited to 'gr-digital/examples/CMakeLists.txt')

diff --git a/gr-digital/examples/CMakeLists.txt b/gr-digital/examples/CMakeLists.txt
index 12fca6009a..33d257e59f 100644
--- a/gr-digital/examples/CMakeLists.txt
+++ b/gr-digital/examples/CMakeLists.txt
@@ -19,6 +19,7 @@
 
 include(GrPython)
 
+# Base stuff
 GR_PYTHON_INSTALL(PROGRAMS
     example_costas.py
     example_fll.py
@@ -30,6 +31,7 @@ GR_PYTHON_INSTALL(PROGRAMS
     COMPONENT "digital_python"
 )
 
+# Narrowband
 GR_PYTHON_INSTALL(PROGRAMS
     narrowband/transmit_path.py
     narrowband/receive_path.py
@@ -45,6 +47,7 @@ GR_PYTHON_INSTALL(PROGRAMS
     COMPONENT "digital_python"
 )
 
+# OFDM
 GR_PYTHON_INSTALL(PROGRAMS
     ofdm/benchmark_add_channel.py
     ofdm/benchmark_rx.py
@@ -58,3 +61,16 @@ GR_PYTHON_INSTALL(PROGRAMS
     DESTINATION ${GR_PKG_DIGITAL_EXAMPLES_DIR}/ofdm
     COMPONENT "digital_python"
 )
+
+# DEMOD
+install(
+    FILES
+    demod/digital_freq_lock.grc
+    demod/mpsk_demod.grc
+    demod/pam_sync.grc
+    demod/pam_timing.grc
+    demod/ber_simulation.grc
+    demod/dpsk_loopback.grc   
+    DESTINATION ${GR_PKG_DIGITAL_EXAMPLES_DIR}/demod
+    COMPONENT "digital_python"
+)
-- 
cgit v1.2.3