From e788c523d4f8de3efd64a64f148ac1bf25ea032d Mon Sep 17 00:00:00 2001
From: Michael L Dickens <mlk@alum.mit.edu>
Date: Tue, 1 Jan 2013 21:42:23 -0500
Subject: Tweak INCLUDE dirs such that INCLUDE_DIRECTORIES and LINK_DIRECTORIES
 are ordered as: internal build and source for this component, other
 components (internal build and source, or already installed), non-project
 non-system dependencies (e.g., Qt, Boost, Python), system dependencies (e.g.,
 CoreAudio).

---
 gr-blocks/swig/CMakeLists.txt | 4 +++-
 1 file changed, 3 insertions(+), 1 deletion(-)

(limited to 'gr-blocks/swig/CMakeLists.txt')

diff --git a/gr-blocks/swig/CMakeLists.txt b/gr-blocks/swig/CMakeLists.txt
index fb29789f08..aa5c7bf55e 100644
--- a/gr-blocks/swig/CMakeLists.txt
+++ b/gr-blocks/swig/CMakeLists.txt
@@ -24,9 +24,11 @@ include(GrPython)
 include(GrSwig)
 
 set(GR_SWIG_INCLUDE_DIRS
+    ${CMAKE_CURRENT_BINARY_DIR}/../include
     ${GR_BLOCKS_INCLUDE_DIRS}
     ${GNURADIO_CORE_SWIG_INCLUDE_DIRS}
-    ${CMAKE_CURRENT_BINARY_DIR}/../include
+    ${GRUEL_INCLUDE_DIRS}
+    ${Boost_INCLUDE_DIRS}
 )
 
 set(GR_SWIG_DOC_FILE ${CMAKE_CURRENT_BINARY_DIR}/blocks_swig_doc.i)
-- 
cgit v1.2.3