summaryrefslogtreecommitdiff
path: root/gr-wxgui/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-wxgui/CMakeLists.txt')
-rw-r--r--gr-wxgui/CMakeLists.txt33
1 files changed, 0 insertions, 33 deletions
diff --git a/gr-wxgui/CMakeLists.txt b/gr-wxgui/CMakeLists.txt
index 3d8b59c691..d77e36ad4a 100644
--- a/gr-wxgui/CMakeLists.txt
+++ b/gr-wxgui/CMakeLists.txt
@@ -59,37 +59,6 @@ GR_SET_GLOBAL(GR_WXGUI_INCLUDE_DIRS
)
########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_COMPONENT("wxgui_runtime"
- DISPLAY_NAME "WxGUI"
- DESCRIPTION "Wx GUI plotter widgets and grc wrappers"
- DEPENDS "runtime_python"
-)
-
-CPACK_COMPONENT("wxgui_devel"
- GROUP "WxGUI"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("wxgui_python"
- GROUP "WxGUI"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime; GRC xml files"
- DEPENDS "runtime_python;wxgui_runtime"
-)
-
-CPACK_COMPONENT("wxgui_swig"
- GROUP "WxGUI"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;wxgui_python;wxgui_devel"
-)
-
-########################################################################
# Create Pkg Config File
########################################################################
configure_file(
@@ -100,7 +69,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gr-wxgui.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "wxgui"
)
########################################################################
@@ -109,7 +77,6 @@ install(
install(
FILES ${CMAKE_CURRENT_SOURCE_DIR}/gr-wxgui.conf
DESTINATION ${GR_PREFSDIR}
- COMPONENT "wxgui"
)
########################################################################