summaryrefslogtreecommitdiff
path: root/gr-vocoder/swig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-vocoder/swig/CMakeLists.txt')
-rw-r--r--gr-vocoder/swig/CMakeLists.txt16
1 files changed, 13 insertions, 3 deletions
diff --git a/gr-vocoder/swig/CMakeLists.txt b/gr-vocoder/swig/CMakeLists.txt
index 26623969a7..60f2f47329 100644
--- a/gr-vocoder/swig/CMakeLists.txt
+++ b/gr-vocoder/swig/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright 2011 Free Software Foundation, Inc.
+# Copyright 2011,2016 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -33,6 +33,18 @@ if(ENABLE_GR_CTRLPORT)
list(APPEND GR_SWIG_FLAGS "-DGR_CTRLPORT")
endif(ENABLE_GR_CTRLPORT)
+if(LIBCODEC2_FOUND)
+ list(APPEND GR_SWIG_FLAGS "-DLIBCODEC2_FOUND")
+endif(LIBCODEC2_FOUND)
+
+if(LIBCODEC2_HAS_FREEDV_API)
+ list(APPEND GR_SWIG_FLAGS "-DLIBCODEC2_HAS_FREEDV_API")
+endif(LIBCODEC2_HAS_FREEDV_API)
+
+if(LIBGSM_FOUND)
+ list(APPEND GR_SWIG_FLAGS "-DLIBGSM_FOUND")
+endif(LIBGSM_FOUND)
+
set(GR_SWIG_DOC_FILE ${CMAKE_CURRENT_BINARY_DIR}/vocoder_swig_doc.i)
set(GR_SWIG_DOC_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/../include/gnuradio/vocoder)
set(GR_SWIG_DOCS_TARGET_DEPS runtime_swig_swig_doc)
@@ -44,7 +56,6 @@ GR_SWIG_MAKE(vocoder_swig vocoder_swig.i)
GR_SWIG_INSTALL(
TARGETS vocoder_swig
DESTINATION ${GR_PYTHON_DIR}/gnuradio/vocoder
- COMPONENT "vocoder_python"
)
install(
@@ -52,5 +63,4 @@ install(
vocoder_swig.i
${CMAKE_CURRENT_BINARY_DIR}/vocoder_swig_doc.i
DESTINATION ${GR_INCLUDE_DIR}/gnuradio/swig
- COMPONENT "vocoder_swig"
)