summaryrefslogtreecommitdiff
path: root/gr-trellis/swig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-trellis/swig/CMakeLists.txt')
-rw-r--r--gr-trellis/swig/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/gr-trellis/swig/CMakeLists.txt b/gr-trellis/swig/CMakeLists.txt
new file mode 100644
index 0000000000..36a5f850ad
--- /dev/null
+++ b/gr-trellis/swig/CMakeLists.txt
@@ -0,0 +1,57 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Setup swig generation
+########################################################################
+include(GrPython)
+include(GrSwig)
+
+set(GR_SWIG_INCLUDE_DIRS
+ ${GR_TRELLIS_INCLUDE_DIRS}
+ ${GR_DIGITAL_INCLUDE_DIRS}
+ ${GNURADIO_CORE_SWIG_INCLUDE_DIRS}
+)
+
+set(GR_SWIG_LIBRARIES gnuradio-trellis gnuradio-digital)
+
+if(ENABLE_GR_CTRLPORT)
+ ADD_DEFINITIONS(-DGR_CTRLPORT)
+endif(ENABLE_GR_CTRLPORT)
+
+# Setup swig docs to depend on includes and pull in from build directory
+set(GR_SWIG_TARGET_DEPS trellis_generated_includes)
+set(GR_SWIG_DOC_FILE ${CMAKE_CURRENT_BINARY_DIR}/trellis_swig_doc.i)
+set(GR_SWIG_DOC_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/../lib)
+
+GR_SWIG_MAKE(trellis_swig trellis_swig.i)
+
+GR_SWIG_INSTALL(
+ TARGETS trellis_swig
+ DESTINATION ${GR_PYTHON_DIR}/gnuradio/trellis
+ COMPONENT "trellis_python"
+)
+
+install(
+ FILES
+ trellis_swig.i
+ ${CMAKE_CURRENT_BINARY_DIR}/trellis_swig_doc.i
+ DESTINATION ${GR_INCLUDE_DIR}/gnuradio/swig
+ COMPONENT "trellis_swig"
+)