summaryrefslogtreecommitdiff
path: root/gr-trellis/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-trellis/src/CMakeLists.txt')
-rw-r--r--gr-trellis/src/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/gr-trellis/src/CMakeLists.txt b/gr-trellis/src/CMakeLists.txt
new file mode 100644
index 0000000000..56db84a3e4
--- /dev/null
+++ b/gr-trellis/src/CMakeLists.txt
@@ -0,0 +1,28 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+########################################################################
+# Add subdirectories
+########################################################################
+add_subdirectory(lib)
+if(ENABLE_PYTHON)
+ add_subdirectory(python)
+ add_subdirectory(examples/python)
+ add_subdirectory(examples/grc)
+endif(ENABLE_PYTHON)