summaryrefslogtreecommitdiff
path: root/gr-noaa/swig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-noaa/swig/CMakeLists.txt')
-rw-r--r--gr-noaa/swig/CMakeLists.txt56
1 files changed, 0 insertions, 56 deletions
diff --git a/gr-noaa/swig/CMakeLists.txt b/gr-noaa/swig/CMakeLists.txt
deleted file mode 100644
index 8d39b678f8..0000000000
--- a/gr-noaa/swig/CMakeLists.txt
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 2011,2012 Free Software Foundation, Inc.
-#
-# This file is part of GNU Radio
-#
-# GNU Radio is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3, or (at your option)
-# any later version.
-#
-# GNU Radio is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Radio; see the file COPYING. If not, write to
-# the Free Software Foundation, Inc., 51 Franklin Street,
-# Boston, MA 02110-1301, USA.
-
-########################################################################
-# Setup swig generation
-########################################################################
-include(GrPython)
-include(GrSwig)
-
-set(GR_SWIG_INCLUDE_DIRS
- ${GR_NOAA_INCLUDE_DIRS}
- ${GNURADIO_RUNTIME_SWIG_INCLUDE_DIRS}
- ${Boost_INCLUDE_DIRS}
-)
-
-if(ENABLE_GR_CTRLPORT)
- list(APPEND GR_SWIG_FLAGS "-DGR_CTRLPORT")
-endif(ENABLE_GR_CTRLPORT)
-
-set(GR_SWIG_DOC_FILE ${CMAKE_CURRENT_BINARY_DIR}/noaa_swig_doc.i)
-set(GR_SWIG_DOC_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/../include/gnuradio/noaa)
-set(GR_SWIG_DOCS_TARGET_DEPS runtime_swig_swig_doc)
-
-set(GR_SWIG_LIBRARIES gnuradio-noaa)
-
-GR_SWIG_MAKE(noaa_swig noaa_swig.i)
-
-GR_SWIG_INSTALL(
- TARGETS noaa_swig
- DESTINATION ${GR_PYTHON_DIR}/gnuradio/noaa
- COMPONENT "noaa_python"
-)
-
-install(
- FILES
- noaa_swig.i
- ${CMAKE_CURRENT_BINARY_DIR}/noaa_swig_doc.i
- DESTINATION ${GR_INCLUDE_DIR}/gnuradio/swig
- COMPONENT "noaa_swig"
-)