summaryrefslogtreecommitdiff
path: root/gr-howto-write-a-block/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-howto-write-a-block/lib/CMakeLists.txt')
-rw-r--r--gr-howto-write-a-block/lib/CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/gr-howto-write-a-block/lib/CMakeLists.txt b/gr-howto-write-a-block/lib/CMakeLists.txt
index 835ae02d60..83b510e3f9 100644
--- a/gr-howto-write-a-block/lib/CMakeLists.txt
+++ b/gr-howto-write-a-block/lib/CMakeLists.txt
@@ -1,4 +1,4 @@
-# Copyright 2011 Free Software Foundation, Inc.
+# Copyright 2011,2012 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -22,7 +22,7 @@
########################################################################
include(GrPlatform) #define LIB_SUFFIX
-add_library(gnuradio-howto SHARED howto_square_ff.cc howto_square2_ff.cc)
+add_library(gnuradio-howto SHARED square_ff_impl.cc square2_ff_impl.cc)
target_link_libraries(gnuradio-howto ${Boost_LIBRARIES} ${GRUEL_LIBRARIES} ${GNURADIO_CORE_LIBRARIES})
set_target_properties(gnuradio-howto PROPERTIES DEFINE_SYMBOL "gnuradio_howto_EXPORTS")
@@ -45,10 +45,10 @@ set(GR_TEST_TARGET_DEPS gnuradio-howto)
#turn each test cpp file into an executable with an int main() function
add_definitions(-DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN)
-add_executable(qa_howto_square_ff qa_howto_square_ff.cc)
-target_link_libraries(qa_howto_square_ff gnuradio-howto ${Boost_LIBRARIES})
-GR_ADD_TEST(qa_howto_square_ff qa_howto_square_ff)
+add_executable(qa_square_ff qa_square_ff.cc)
+target_link_libraries(qa_square_ff gnuradio-howto ${Boost_LIBRARIES})
+GR_ADD_TEST(qa_square_ff qa_square_ff)
-add_executable(qa_howto_square2_ff qa_howto_square2_ff.cc)
-target_link_libraries(qa_howto_square2_ff gnuradio-howto ${Boost_LIBRARIES})
-GR_ADD_TEST(qa_howto_square2_ff qa_howto_square2_ff)
+add_executable(qa_square2_ff qa_square2_ff.cc)
+target_link_libraries(qa_square2_ff gnuradio-howto ${Boost_LIBRARIES})
+GR_ADD_TEST(qa_square2_ff qa_square2_ff)