summaryrefslogtreecommitdiff
path: root/gr-dtv/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-dtv/CMakeLists.txt')
-rw-r--r--gr-dtv/CMakeLists.txt35
1 files changed, 0 insertions, 35 deletions
diff --git a/gr-dtv/CMakeLists.txt b/gr-dtv/CMakeLists.txt
index 9cca0b0f5c..365df16aa1 100644
--- a/gr-dtv/CMakeLists.txt
+++ b/gr-dtv/CMakeLists.txt
@@ -53,40 +53,6 @@ SET(GR_PKG_DTV_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/dtv)
if(ENABLE_GR_DTV)
########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_SET(CPACK_COMPONENT_GROUP_DTV_DESCRIPTION "GNU Radio DTV Blocks")
-
-CPACK_COMPONENT("dtv_runtime"
- GROUP "DTV"
- DISPLAY_NAME "Runtime"
- DESCRIPTION "Runtime"
- DEPENDS "runtime_runtime"
-)
-
-CPACK_COMPONENT("dtv_devel"
- GROUP "DTV"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("dtv_python"
- GROUP "DTV"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime; GRC xml files"
- DEPENDS "runtime_python;dtv_runtime"
-)
-
-CPACK_COMPONENT("dtv_swig"
- GROUP "DTV"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;dtv_python;dtv_devel"
-)
-
-########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include/gnuradio/dtv)
@@ -111,7 +77,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-dtv.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "dtv_devel"
)
endif(ENABLE_GR_DTV)