summaryrefslogtreecommitdiff
path: root/gr-digital/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-digital/CMakeLists.txt')
-rw-r--r--gr-digital/CMakeLists.txt44
1 files changed, 4 insertions, 40 deletions
diff --git a/gr-digital/CMakeLists.txt b/gr-digital/CMakeLists.txt
index 5edf96e8d5..cefaa6ee95 100644
--- a/gr-digital/CMakeLists.txt
+++ b/gr-digital/CMakeLists.txt
@@ -1,17 +1,17 @@
# Copyright 2011 Free Software Foundation, Inc.
-#
+#
# This file is part of GNU Radio
-#
+#
# GNU Radio is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 3, or (at your option)
# any later version.
-#
+#
# GNU Radio is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-#
+#
# You should have received a copy of the GNU General Public License
# along with GNU Radio; see the file COPYING. If not, write to
# the Free Software Foundation, Inc., 51 Franklin Street,
@@ -53,40 +53,6 @@ SET(GR_PKG_DIGITAL_EXAMPLES_DIR ${GR_PKG_DATA_DIR}/examples/digital)
if(ENABLE_GR_DIGITAL)
########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_SET(CPACK_COMPONENT_GROUP_DIGITAL_DESCRIPTION "GNU Radio Digital Blocks")
-
-CPACK_COMPONENT("digital_runtime"
- GROUP "Digital"
- DISPLAY_NAME "Runtime"
- DESCRIPTION "Dynamic link libraries"
- DEPENDS "runtime_runtime"
-)
-
-CPACK_COMPONENT("digital_devel"
- GROUP "Digital"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("digital_python"
- GROUP "Digital"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime"
- DEPENDS "runtime_python;digital_runtime"
-)
-
-CPACK_COMPONENT("digital_swig"
- GROUP "Digital"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;digital_python;digital_devel"
-)
-
-########################################################################
# Add subdirectories
########################################################################
add_subdirectory(include/gnuradio/digital)
@@ -95,7 +61,6 @@ add_subdirectory(doc)
if(ENABLE_PYTHON)
add_subdirectory(swig)
add_subdirectory(python/digital)
- add_subdirectory(python/grc_gnuradio)
add_subdirectory(grc)
add_subdirectory(examples)
endif(ENABLE_PYTHON)
@@ -111,7 +76,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-digital.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "digital_devel"
)
endif(ENABLE_GR_DIGITAL)