summaryrefslogtreecommitdiff
path: root/gr-blocks/include/blocks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-blocks/include/blocks/CMakeLists.txt')
-rw-r--r--gr-blocks/include/blocks/CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/gr-blocks/include/blocks/CMakeLists.txt b/gr-blocks/include/blocks/CMakeLists.txt
index bb9c1c79df..a88eaeeb26 100644
--- a/gr-blocks/include/blocks/CMakeLists.txt
+++ b/gr-blocks/include/blocks/CMakeLists.txt
@@ -65,8 +65,8 @@ endmacro(expand_h)
# Invoke macro to generate various sources
########################################################################
expand_h(add_XX ss ii cc)
-expand_h(add_const_XX ss ii ff cc)
-expand_h(add_const_vXX ss ii ff cc)
+expand_h(add_const_XX bb ss ii ff cc)
+expand_h(add_const_vXX bb ss ii ff cc)
expand_h(and_XX bb ss ii)
expand_h(and_const_XX bb ss ii)
expand_h(argmax_XX fs is ss)
@@ -164,6 +164,7 @@ install(FILES
pdu.h
pdu_to_tagged_stream.h
peak_detector2_fb.h
+ random_pdu.h
probe_rate.h
regenerate_bb.h
repack_bits_bb.h
@@ -201,3 +202,12 @@ install(FILES
DESTINATION ${GR_INCLUDE_DIR}/gnuradio/blocks
COMPONENT "blocks_devel"
)
+
+if(ENABLE_GR_CTRLPORT)
+install(FILES
+ ctrlport_probe_c.h
+ ctrlport_probe2_c.h
+ DESTINATION ${GR_INCLUDE_DIR}/gnuradio/blocks
+ COMPONENT "blocks_devel"
+)
+endif(ENABLE_GR_CTRLPORT)