summaryrefslogtreecommitdiff
path: root/gr-analog/include/analog/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gr-analog/include/analog/CMakeLists.txt')
-rw-r--r--gr-analog/include/analog/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/gr-analog/include/analog/CMakeLists.txt b/gr-analog/include/analog/CMakeLists.txt
index 4de94a88b3..1ae24f8c28 100644
--- a/gr-analog/include/analog/CMakeLists.txt
+++ b/gr-analog/include/analog/CMakeLists.txt
@@ -65,6 +65,7 @@ endmacro(expand_h)
# Invoke macro to generate various sources
#######################################################################
expand_h(noise_source_X s i f c)
+expand_h(fastnoise_source_X s i f c)
expand_h(sig_source_X s i f c)
add_custom_target(analog_generated_includes DEPENDS
@@ -75,9 +76,10 @@ add_custom_target(analog_generated_includes DEPENDS
# Install header files
########################################################################
install(FILES
- ${analog_generated_includes}
+ ${generated_includes}
api.h
cpm.h
+ noise_type.h
agc.h
agc2.h
squelch_base_ff.h
@@ -102,7 +104,6 @@ install(FILES
pwr_squelch_ff.h
quadrature_demod_cf.h
rail_ff.h
- rotator.h
sig_source_waveform.h
simple_squelch_cc.h
DESTINATION ${GR_INCLUDE_DIR}/gnuradio/analog