summaryrefslogtreecommitdiff
path: root/gnuradio-runtime/swig/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-runtime/swig/CMakeLists.txt')
-rw-r--r--gnuradio-runtime/swig/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/gnuradio-runtime/swig/CMakeLists.txt b/gnuradio-runtime/swig/CMakeLists.txt
index ca9ddd4039..698283fe4d 100644
--- a/gnuradio-runtime/swig/CMakeLists.txt
+++ b/gnuradio-runtime/swig/CMakeLists.txt
@@ -52,7 +52,6 @@ GR_SWIG_MAKE(pmt_swig pmt_swig.i)
GR_SWIG_INSTALL(
TARGETS pmt_swig
DESTINATION ${GR_PYTHON_DIR}/pmt
- COMPONENT "runtime_python"
)
add_custom_target(pmt_swig DEPENDS ${SWIG_MODULE_pmt_swig_REAL_NAME})
@@ -61,12 +60,6 @@ add_custom_target(pmt_swig DEPENDS ${SWIG_MODULE_pmt_swig_REAL_NAME})
# Build gnuradio-runtime swig
###############################################################
-# Only use if log4cpp is installed
-# Define ENABLE_GR_LOG for the .i file to ignore it.
-if(ENABLE_GR_LOG)
- SET(GR_SWIG_FLAGS "-DENABLE_GR_LOG")
-endif(ENABLE_GR_LOG)
-
if(ENABLE_GR_CTRLPORT)
ADD_DEFINITIONS(-DGR_CTRLPORT)
list(APPEND GR_SWIG_FLAGS -DGR_CTRLPORT)
@@ -82,7 +75,6 @@ GR_SWIG_MAKE(runtime_swig runtime_swig.i)
GR_SWIG_INSTALL(
TARGETS runtime_swig
DESTINATION ${GR_PYTHON_DIR}/gnuradio/gr
- COMPONENT "runtime_python"
)
install(
@@ -114,7 +106,6 @@ install(
pmt_swig.i
prefs.i
realtime.i
- single_threaded_scheduler.i
sync_block.i
sync_decimator.i
sync_interpolator.i
@@ -124,5 +115,4 @@ install(
${CMAKE_CURRENT_BINARY_DIR}/runtime_swig_doc.i
${CMAKE_CURRENT_BINARY_DIR}/pmt_swig_doc.i
DESTINATION ${GR_INCLUDE_DIR}/gnuradio/swig
- COMPONENT "runtime_swig"
)