summaryrefslogtreecommitdiff
path: root/gnuradio-runtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'gnuradio-runtime/CMakeLists.txt')
-rw-r--r--gnuradio-runtime/CMakeLists.txt39
1 files changed, 1 insertions, 38 deletions
diff --git a/gnuradio-runtime/CMakeLists.txt b/gnuradio-runtime/CMakeLists.txt
index 961647f5f7..2f9c86173d 100644
--- a/gnuradio-runtime/CMakeLists.txt
+++ b/gnuradio-runtime/CMakeLists.txt
@@ -37,6 +37,7 @@ GR_REGISTER_COMPONENT("gnuradio-runtime" ENABLE_GNURADIO_RUNTIME
Boost_FOUND
ENABLE_VOLK
PYTHONINTERP_FOUND
+ LOG4CPP_FOUND
)
GR_SET_GLOBAL(GNURADIO_RUNTIME_INCLUDE_DIRS
@@ -80,39 +81,6 @@ get_filename_component(GR_RUNTIME_PYTHONPATH
)
GR_SET_GLOBAL(GR_RUNTIME_PYTHONPATH ${GR_RUNTIME_PYTHONPATH})
-########################################################################
-# Setup CPack components
-########################################################################
-include(GrPackage)
-CPACK_SET(CPACK_COMPONENT_GROUP_RUNTIME_DESCRIPTION "GNU Radio Runtime")
-
-CPACK_COMPONENT("runtime_runtime"
- GROUP "Runtime"
- DISPLAY_NAME "Runtime"
- DESCRIPTION "Dynamic link libraries"
- DEPENDS "runtime_runtime"
-)
-
-CPACK_COMPONENT("runtime_devel"
- GROUP "Runtime"
- DISPLAY_NAME "Development"
- DESCRIPTION "C++ headers, package config, import libraries"
- DEPENDS "runtime_devel"
-)
-
-CPACK_COMPONENT("runtime_python"
- GROUP "Runtime"
- DISPLAY_NAME "Python"
- DESCRIPTION "Python modules for runtime"
- DEPENDS "runtime_python;runtime_runtime"
-)
-
-CPACK_COMPONENT("runtime_swig"
- GROUP "Runtime"
- DISPLAY_NAME "SWIG"
- DESCRIPTION "SWIG development .i files"
- DEPENDS "runtime_swig;runtime_python;runtime_devel"
-)
configure_file(
${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-runtime.conf.in
${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.conf
@@ -121,16 +89,12 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.conf
DESTINATION ${GR_PREFSDIR}
- COMPONENT "runtime_runtime"
)
-if(ENABLE_GR_LOG AND HAVE_LOG4CPP)
install(FILES
${CMAKE_CURRENT_SOURCE_DIR}/gr_log_default.conf
DESTINATION ${GR_PREFSDIR}
- COMPONENT "runtime_runtime"
)
-endif(ENABLE_GR_LOG AND HAVE_LOG4CPP)
########################################################################
# Add subdirectories
@@ -155,7 +119,6 @@ configure_file(
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/gnuradio-runtime.pc
DESTINATION ${GR_LIBRARY_DIR}/pkgconfig
- COMPONENT "runtime_devel"
)
endif(ENABLE_GNURADIO_RUNTIME)