summaryrefslogtreecommitdiff
path: root/docs/doxygen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'docs/doxygen/CMakeLists.txt')
-rw-r--r--docs/doxygen/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/docs/doxygen/CMakeLists.txt b/docs/doxygen/CMakeLists.txt
index a59159a691..8498511f9d 100644
--- a/docs/doxygen/CMakeLists.txt
+++ b/docs/doxygen/CMakeLists.txt
@@ -37,13 +37,9 @@ configure_file(
set(BUILT_DIRS ${CMAKE_CURRENT_BINARY_DIR}/xml ${CMAKE_CURRENT_BINARY_DIR}/html)
-if(ENABLE_GRUEL)
+if(ENABLE_GNURADIO_RUNTIME)
list(APPEND GENERATED_DEPS pmt_generated)
-endif(ENABLE_GRUEL)
-
-if(ENABLE_GR_CORE)
- list(APPEND GENERATED_DEPS general_generated gengen_generated filter_generated)
-endif(ENABLE_GR_CORE)
+endif(ENABLE_GNURADIO_RUNTIME)
if(ENABLE_GR_BLOCKS)
list(APPEND GENERATED_DEPS blocks_generated_includes)
@@ -57,6 +53,10 @@ if(ENABLE_GR_DIGITAL)
list(APPEND GENERATED_DEPS digital_generated_includes)
endif(ENABLE_GR_DIGITAL)
+if(ENABLE_GR_FEC)
+ list(APPEND GENERATED_DEPS fec_generated_includes)
+endif(ENABLE_GR_FEC)
+
if(ENABLE_GR_FILTER)
list(APPEND GENERATED_DEPS filter_generated_includes)
endif(ENABLE_GR_FILTER)